Erro ao Instalar v 0.7.2

edited June 2014 in Suporte

Oops!
Erro

file() expects at least 1 parameter, 0 given

Local

/var/www/novosga/core/view/TemplateBuilder.php:293
OBS! Está instalada a versão PHP5.3.10 no ubuntu 12.04.2 LTS
Tagged:

Comments

  • rogeriolinorogeriolino Big Time
    edited June 2014
    Em algumas instalações do PHP está ocorrendo esse problema. Então para resolver, você pode alterar o arquivo TemplateBuilder.php conforme abaixo:

    Na linha 293, aonde está:

    $h = (is_callable($header[$i])) ? $header[$i]() : $header[$i];
    Passa ficar:

    $h = (!is_string($header[$i]) && is_callable($header[$i])) ? $header[$i]() : $header[$i];
This discussion has been closed.