Instalação da versão 1.0.0

esdras_laroqueesdras_laroque Entry Level
edited April 2014 in Suporte
Tento instalar seguindo os tutoriais daqui, a versão 1.0.0, e não consigo.

Fiquei parado neste erro, após executar o comando "composer":
Problem 1
- slim/slim 2.3.0 requires ext-mcrypt * -> the requested PHP extension mcrypt is missing from your system.
- novosga/core 1.0.0 requires slim/slim 2.3 -> satisfiable by slim/slim[2.3.0].
- Installation request for novosga/core 1.0.0 -> satisfiable by novosga/core[1.0.0].
De início, imaginei que era porque faltava o pacote php-mcrypt. Mas já instalei o pacote e não deu certo. O erro persistiu.

O que fazer??
Tagged:

Comments

  • Consegui resolver o problema. Estou usando CentOS 6.5

    Após instalar os pacotes:
    php-mcrypt-5.3.3-1.el6.rf.x86_64
    libmcrypt-2.5.7-1.2.el6.rf.x86_64

    Verifiquei que ele criou um arquivo /etc/php.d/mcrypt.ini, porém o carregamento do módulo estava descrito de maneira errada.

    Para normalizar, alterei a linha:
    extension=module.so
    Por:
    extension=mcrypt.so
    Isso resolveu o meu problema. O composer conseguiu instalar as dependências.
This discussion has been closed.